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KEY TERMS 
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1.1 STARTING STATA 

Stata can be started several ways. First, there may be shortcut on the desktop that you can double-
click. For the Stata Release 15 it will look something like this: 
 

 
 
Your author has the MP version of Stata, so it shows StataMP. Earlier versions of Stata have a 
similar looking Icon, but of course with a different number. Alternatively, using the Windows 
menu, click the Start > All Apps > Stata 15. 

A second way is to simply locate a Stata data file, with *.dta extension, and double-click. 
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1.2 THE OPENING DISPLAY  

Once Stata is started a display will appear that contains windows titled  
 

Command—this is where Stata commands are typed 
Results—output from commands, and error messages, appear here 
Review—a listing of commands recently executed 
Variables—names of variables in data and labels (if created) 
 

 
 
Across the top are Stata pull-down menus. We will explore the use of many of these. In the lower 
left-hand corner is the current path to the working directory where Stata looks for and saves its 
files, such as graphs and datasets, by default. We will change this in a moment. 

1.3 EXITING STATA 

To end a Stata session click on File  
 

 
 
and the Exit on the pull-down menu 
 



4   Chapter 1 

 
 
We will denote sequential clicking commands like this as File > Exit. Alternatively, simply type  
 

exit  

 
in the Command window and press Enter.  
 

 

1.4 STATA DATA FILES FOR POE5 

Stata data files have the extension *.dta. These files should not be opened with any program but 
Stata. If you locate a *.dta file using double-click it will also start Stata. 

For Principles of Econometrics, 5th Edition, POE5 hereafter, all of the data used in the book 
has been converted into Stata data files for your use. These files, in a format compatible with Stata 
Version 9 and later can be found at 

1. The John Wiley & Sons website for the book: http://www.wiley.com/college/hill. You can 
download the entire collection of Stata data files to your computer or a “memory stick” 
with adequate storage. 

2. Book data and other resources are available at the authors’ website 
http://www.principlesofeconometrics.com.  

3. Individual data files, and other book materials, can found at the Stata web site 
http://www.stata.com/texts/s4poe5/.  
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1.4.1 A working directory 
In this book our working directory is poe5 within the Documents directory. We store all of our 
programs and graphs there by default. However, within the poe5 directory we have the sub-
directory stata containing all the Stata datasets used in the textbook POE5, so that the datasets are 
separated from do-files, graphs, etc. We are doing this for our convenience and if you are in a 
laboratory setting this is a bad choice. If you are working in a computer laboratory, you may want 
to have a storage device such as a “flash” or “travel” drive. These are large enough to hold the Stata 
data files and definition files. Or you may use Dropbox or something similar.  

To change the working directory use the pull-down menu File > Change Working Directory. 
In the resulting dialog box navigate to your preferred location and click OK. 
 

          
 
Stata will show the implied command 

 

 
 
Or enter the command into the Command window and press Enter.  
 

 
 
The result of this command is 
 

C:\Users\eohill\Documents\poe5
. cd "C:\Users\eohill\Documents\poe5"
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Note that in the Results window the command is echoed, and it appears in the Review window as 
well. The new path is indicated at the bottom left of the screen. 

Stata has a useful device to reach the folder. Enter the command cd ~/Documents/poe5. The 
“~” takes you to your home folder, whatever it might be, and then to Documents/poe5. 

1.5 OPENING STATA DATA FILES 

There are several ways to open, or load, Stata data files. We will explain a couple of them using 
the data file cps5_small.dta. 

1.5.1 Using the toolbar 
To open a Stata data file using the tool bar click the Open (use) icon on the Stata toolbar. 
 

 
 
Locate the file you wish to open, select it, and click Open. In the Review window the implied Stata 
command is shown.  
 

use "C:\Users\eohill\Documents\poe5\stata\cps5_small.dta" 
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1.5.2 The use command 
With Stata started,  
 

 
 
If you have a data file already open, and have changed it in some way, Stata will reply with an error 
message. This feature will prevent you from losing changes to a data file you may wish to save. If 
this happens, you can either save the previous data file [more on this below], or enter the command 
 

clear 

 
The clear command will remove data is in Stata’s memory. If you want to open the data file and 
clear memory, enter 
 

use "C:\Users\eohill\Documents\poe5\stata\cps5_small.dta", clear 

 

In this manual we will assume your working directory has the data in a subdirectory called stata 
so that to open a data set we use 

 
use stata/cps5_small, clear 

1.5.3 Using files on the internet 
Stata offers a nice option if you are connected to the internet. Files can be loaded from a web site. 
The Stata data files are stored at the author’s web site 
 

http://www.principlesofeconometrics.com/poe5/data/stata/  
 

To access the data file cps5_small directly from this internet site enter the command 
 

use http://www.principlesofeconometrics.com/poe5/data/stata/cps5_small 

 
Once the data are loaded onto your machine, you can save it using File > Save as and filling in the 
resulting dialog box. 

The data files and more are also located at the Stata website 
 

https://www.stata.com/texts/s4poe5/ 

1.5.4 Locating book files on the internet 
If you would like to browse the book data sets, use your internet browser to visit 
http://www.principlesofeconometrics.com where you will find individual data files listed, along 
with other book materials. You can download all the data files at once in a “zip” format, or 
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download individual files. You should also download the data definition files which contain 
variable names, descriptions, and summary statistics. 

1.6 THE VARIABLES WINDOW 

In the Variables window the data file variables are listed. Using the default layout, the list of 
variables is shown in the upper right-hand corner. To see the full variable list with characteristics 
follow the path Window > Variables Manager. 
 

                       
 

 
 
Also shown are variable Labels, if they are present, along with the Type of variable and its Format. 
We will only display the variable Name and Label in future screen shots. Labels are useful and 
can be easily added, changed or deleted in Variables Manager. 
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1.6.1 Using the data utility for a single label 
On the Stata pull-down menu select Data > Data utilities > Label utilities > Label Variable. That 
is, 

 

 
 

In the resulting dialog box, you can alter the existing label by choosing Attach a label to a 
variable, choosing the variable from the Variable: pull-down list and typing in the New variable 
label. Click OK and the dialog box will close. Click Submit and the dialog box will remain open. 
 

 
 
The Command is 

 
This will create the label, and it will write over an already existing label for wage. In the dialog box 
you can also choose to Remove a label.  

1.7 DESCRIBING DATA AND OBTAINING SUMMARY STATISTICS 

There are a few things you should do each time a data file is opened. First, enter the Command  
 

describe 

. label variable wage "earnings per hour, dollars"



10   Chapter 1 

 
This produces a summary of the dataset in memory, including a listing of the variables, information 
about them, and their labels. A portion of the results is 
 

 
 
Next, enter the Command  
 

summarize  

 
In the Results window we find the summary statistics. A portion is 
 

 
 
Should you forget a Stata command the pull-down menus virtually assure that with enough clicking 
you can obtain the desired result. To illustrate, click on Statistics on the Stata menu list 

 

 
 
You will find a long list of possible statistical analyses, some of which we will use. For now select 
Summaries, tables, and tests. Select Summary and descriptive statistics, and then Summary 
statistics, as shown below. 
 

 
 
Recall that we will abbreviate such paths of commands as 
 

Statistics > Summaries, tables, and tests > Summary and descriptive 
 statistics > Summary statistics 
 

female          byte    %8.0g                 =1 if female
faminc          long    %12.0g                other family income, $
exper           byte    %8.0g                 potential experience
educ            byte    %8.0g                 years of education
black           byte    %8.0g                 =1 if black
                                                                               
variable name   type    format     label      variable label
              storage   display    value
                                                                               
 size:        24,000                          
 vars:            10                          29 Jun 2016 08:07
  obs:         1,200                          
Contains data from C:\data\poe5stata\cps5_small.dta

. describe

      female        1,200         .44    .4965939          0          1
      faminc        1,200    35304.42    45026.49          0     469000
       exper        1,200    23.37417     13.2693          0         62
        educ        1,200     14.2025    2.890811          0         21
       black        1,200       .0875    .2826842          0          1
                                                                       
    Variable          Obs        Mean    Std. Dev.       Min        Max

. summarize
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A dialog box will open that shows many options. For the basic summary statistics table no options 
are required. Select OK. Stata automatically will provide the summary statistics for all the variables 
in the data set. You can select individual variables by selecting their names in the Variables box. 
The standard display will produce the number of observations, the arithmetic mean, the standard 
deviation, the minimum and maximum of the data values. 

You can also reach the dialog box by entering the command 
 

db summarize 

 

In the lower left hand corner you will see 
 

 
 

Click “?” for help. Click “R” for reset. And Click the last one to copy the command to the 
Clipboard. 

 

 
 

Then, using Ctrl + V, the implied command can be pasted into, for example, the command window. 
 

 
 

Clicking “OK” will create a table of summary statistics, and the dialog box will go away. Clicking 
“Submit” will create the table of summary statistics but will keep the dialog box open. Suppose 
you want summary statistics for just WAGE and EDUC. Click the pull down menu of variables and 
select wage and educ, then Submit 
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The dialog box remains open. Clicking Reset will empty the Variables list so that you can change 
your variable selection easily. 

 
Remark: In the textbook Principles of Econometrics, Fifth Edition (POE5) 
variable names are always upper case italic, such as WAGE and EDUC. Stata 
variable names are lowercase, wage and educ. We will be using some material and 
equations in this manual that are from the textbook so that the upper case italic 
names are used when referring to POE5 examples.  

1.8 The stata help system 
The Stata Help System is very good, and help comes from many directions. First, with Stata open, 
click on Help > Contents 

 

 
 

Clicking on Getting Started leads to some useful links. 
 

        educ        1,200     14.2025    2.890811          0         21
        wage        1,200    23.64004    15.21655       3.94      221.1
                                                                       
    Variable          Obs        Mean    Std. Dev.       Min        Max

. summarize wage educ
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A good place to start is Getting Started with Stata for Windows, or Mac, or Unix. 

 

 

1.8.1 Using keyword search 
In the Command window entering Help with a brief description will usually bring you to a list of 
possibilities. For example, enter the command 

 
help summary statistics 

 
Up comes a list of topics that might be of interest. Once again blue terms are links. Click on 
Summarize.  
 

 
 
The resulting Viewer box shows the command syntax, which can be used when typing commands 
in the Command window, and many options. There is a link to the full PDF manual entry, View 
complete PDF manual entry. In the upper right corner a link to the dialog box. You can reach the 
dialog box at any time by entering the command db summarize. Manual documentation is more 
complete than that in the Viewer from help summarize and usually has several examples.  
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Tip: Note under the syntax that su is underlined. It is the minimum abbreviation. 
This means that the command summarize can be abbreviated as su or, say, summ.  

1.8.2 Opening a dialog box 
If you know the name of the command you want, but do not recall details and options, a dialog box 
can be opened from the Command window. For example, if you wish to summarize the data using 
the dialog box, enter  
 

db summarize 

 
Or, enter help summarize, and click on the link to the dialog box. 

1.8.3 Complete documentation in Stata manuals 
Stata has a complete set of reference manuals consisting of thousands of pages. Stata 15 installation 
comes with these manuals as PDF files.  
 

 
 

1.8.4 Advice 
The Stata help system is one if its most powerful features. Click on Help on the Stata menu, then 
Advice. 
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This is a brief list of suggestions for how to find help. Scroll down to the bottom to find 
 

 
 
Each of the blue words is linked to further screens. You should explore these to get a feel for what 
is available.  
 

 
 

After a brief discussion of Search, there are links to explore. We will connect to each one. 
 

 
 

1.8.5 Stata videos on YouTube 
One of the nice learning tools Stata provides is videos. They are short and demonstrate a wide 
variety of commands. Click on Video tutorials on using Stata. The homepage shows that you can 
search for topics. 
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Click on Videos to see some of the offerings. 

 

 
 

Alternatively go to the Stata.com website for an organized list of videos. See the link 
https://www.stata.com/links/video-tutorials/. 

 

 
 

Under Tour of Stata 15 we find. 
 

 
 

The first two are good places to start. Under Stata basics 
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Under Data management you will find videos on typical tasks such as 

 

 

1.8.6 Statalist 
Join the forum where Stata users of all skill levels ask and answer questions. Visit 
https://www.statalist.org/ If you plan to use Stata for a while, and especially if you are a graduate 
student, then joining is a good idea.  

 

 

1.8.7 Not Elsewhere Classified 
The Stata blog, https://blog.stata.com/, shows recent thoughts and tips from Stata. 

 

 

1.9 STATA COMMAND SYNTAX 

Stata commands have a common syntax. The name of the command, such as summarize is first. 
 

command [varlist] [if] [in] [weight] [, options] 
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The terms in brackets [ ] are various optional command components that could be used. 
 

• [varlist] is the list of variables for which the command is used. 
• [if] is a condition, called a qualifier by Stata, imposed on the command.  
• [in] specifies range of observations for the command. 
• [weight] when some sample observations are to be weighted differently than others. 
• [, options] command options go here.  

 
For more on these options use a Keyword Search for Command syntax, then click Language. 
 

Remark: An important fact to keep in mind when using Stata is that it is case 
sensitive. This means that lower case and capital letters have different meanings. 
That is, Stata considers x to be different from X.  

1.9.1 Syntax of summarize 
Consider the following examples using the syntax features. In each case type the command into the 
Command window and press Enter. For example, assuming the data file cps_small in open,  
 

Summarize wage, detail 

 
summarize wage, detail computes detailed summary statistics for the variable wage. The 

percentiles of wage from smallest to largest are shown, along with additional summary 
statistics (e.g., skewness and kurtosis) that you will learn about. Note that Stata echoes the 
command you have issued with a preceding period (.). 

 

 
 
summarize wage if female==1 computes the simple summary statistics for the females in the 

sample. The variable FEMALE is 1 for females and 0 for males. In the “if qualifier” 
equality is indicated by “==”.  

 
summarize if exper >= 10 computes simple summary statistics for those in the sample whose 

experience (EXPER) is greater than or equal to 10 years, or missing. 
 

99%        72.13          221.1       Kurtosis       27.57869
95%       52.665             99       Skewness       2.959419
90%       43.895          90.13       Variance       231.5435
75%         29.8          80.77
                        Largest       Std. Dev.      15.21655
50%         19.3                      Mean           23.64004

25%           13           5.43       Sum of Wgt.       1,200
10%           10              5       Obs               1,200
 5%          8.5           4.17
 1%          6.8           3.94
      Percentiles      Smallest
                                                             
                    earnings per hour, $

. summarize wage, detail
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summarize in 1/50 computes summary statistics for observations 1 through 50. 
 
summarize wage in 1/50, detail computes detailed summary statistics for the variable wage 

in the first 50 observations. 
 

If you notice at bottom left of the Results window —more—: when the Results 
window is full it pauses and you must click —more— in order for more results to 
appear, or press the space bar. 

1.9.2 Learning syntax using the review window 
At this point you are wondering “How am I supposed to know all this?” Luckily you do not have 
to know it all now, and learning comes with repeated use of Stata. One great tool is the combination 
of pull-down menus and the Review window. Suppose we want detailed summary statistics for 
female wages in the first 500 observations. While you may be able to guess from previous examples 
how to do this, let’s use the point and click approach.  Enter the command 
 

db summarize 

 
In the resulting dialog box we will specify which variables we want to include, and select the option 
providing more detailed statistics. Then click on the by/if/in tab at the top. 
 

 
 
In the new dialog box you can enter the if condition in a box. Click the box next to Use a range of 
observations. Use the selection boxes to choose observations 1 to 500. Then click OK to run and 
close the dialog box, or Submit to run and keep dialog box open. 
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Stata echoes the command, and produces detailed summary statistics for the women in the first 500 
observations 
 

 
 
Now look at the Review window 
 

99%        72.13          80.77       Kurtosis       5.289498
95%         57.7          72.13       Skewness       1.598168
90%        45.01          72.13       Variance       217.4334
75%        26.45          71.15
                        Largest       Std. Dev.      14.74562
50%           18                      Mean           22.84983

25%         12.5           6.17       Sum of Wgt.         234
10%           10           5.78       Obs                 234
 5%         8.11           5.75
 1%         5.78              5
      Percentiles      Smallest
                                                             
                    earnings per hour, $

. summarize wage if female==1 in 1/500, detail
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In the Review window is the list of commands we have typed. You will also find the list of 
commands generated using the dialogs. Line 7 is the command you would enter into the Command 
window to achieve the results of all that pointing and clicking. After experimenting for just a few 
minutes you will learn the syntax for the command summarize. 

Suppose you want to change the last command to include observations 1 to 750. You can enter 
the command  
 

summarize wage if female == 1 in 1/750, detail  

 
into the Command window, but Stata offers us a much easier option. In the Review window, 
simply click on the command in line 7. Instantly, this command appears in the Command window 
 

 
 

Edit this command, changing 500 to 750, then press Enter 
 

 
 
To edit a previously used command, click on that command in the Review window. The past 
command will zip to the Command window, where it can be edited and executed. Not only do you 
obtain new results, but the modified command now appears as the last item in the Review window. 

 
Stata Tip: Many commands will be too long to fit into the Review window. In the 
Command window use Page Up and Page Down to navigate through previous 
commands. 
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1.10 SAVING YOUR WORK 

When you carry out a long Stata session you will want to save your work.  

1.10.1 Copying and pasting 
One option, though certainly not recommended as a general procedure, is to highlight the output 
the Results window, then right-click.  
 

 
 
This gives you options to copy (Ctrl+C) the output as text, and then paste it into a document using 
the shortcut (Ctrl+V) or by clicking the paste icon. If you paste into a word processing document 
you may find that the nicely arranged Stata results become a ragged, hard to read, mess. Part of the 
results might look like 
 
. summarize wage if female == 1 in 1/750, detail 
 
                 earnings per hour, dollars 
------------------------------------------------------------- 
      Percentiles      Smallest 
 1%         5.78           3.94 
 5%         8.25              5 
10%           10           5.75       Obs                 337 
25%         12.5           5.78       Sum of Wgt.         337 
 
50%           19                      Mean           23.18807 
                        Largest       Std. Dev.      14.24291 
75%        28.95          71.15 
90%        44.87          72.13       Variance       202.8605 
95%        53.08          72.13       Skewness       1.378182 
99%        71.15          80.77       Kurtosis       4.671916 
 
This is due to the word processor changing the font. While you may be using Times New Roman 
font for standard text, use Courier New for Stata output.  
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. summarize wage if female == 1 in 1/750, detail 
 
                 earnings per hour, dollars 
------------------------------------------------------------- 
      Percentiles      Smallest 
 1%         5.78           3.94 
 5%         8.25              5 
10%           10           5.75       Obs                 337 
25%         12.5           5.78       Sum of Wgt.         337 
 
50%           19                      Mean           23.18807 
                        Largest       Std. Dev.      14.24291 
75%        28.95          71.15 
90%        44.87          72.13       Variance       202.8605 
95%        53.08          72.13       Skewness       1.378182 
99%        71.15          80.77       Kurtosis       4.671916 

 
Copying the highlighted material as a Picture places your selection into a graphic that makes for 
nice looking output that can be pasted into a document. As a graphic, though, it cannot be edited 
using a word processor.  

1.10.2 Using a log file 
Stata offers a better alternative. In addition to having results in the Results window in Stata, it is a 
very good idea to have all results written (echoed) to an output file, which Stata calls a log file. 
Enter the Stata command 
 

help log 

 
Using the pull-down menu approach, click on the Log Begin/Close/Suspend/Resume icon on the 
Stata toolbar. 

 

 
 
Log files come in two types: a text format, or a smcl format. The smcl format is a Stata Markup 
and Control Language format. To begin a log file in smcl format, enter the command 

 
log using chap01, replace 

 
Since smcl format is the Stata default, it is not necessary to indicate the format type. In the Results 
window we see 
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To close the log file, enter log close.  

Stata is used to view a smcl log file. On the Stata menu choose File > View 
 

 
 
In the resulting dialog box enter the log file pathname, or use Browse to locate it, and then enter 
OK. By default it goes to your working directory. Alternatively, simply enter the command 
 

view chap01.smcl 

 
The log file chap01.smcl opens in a new Viewer window. To print the smcl log file click the printer 
icon.  

Advantages of the smcl formatted log file include the ability to view the formatted output, and 
to easily print it. A disadvantage of *.smcl files is that they cannot be easily viewed without having 
Stata open. They are like *.html files in that while they are text files, they also include lots and lots 
of formatting commands. This means that if you want to work on the output on a machine without 
Stata you are out of luck. Stata allows you the best of both worlds. You can translate the Stata 
*.smcl log files into simple text files. 

On the Stata toolbar select File > Log > Translate. 
 

           
 

 opened on:  31 Jan 2018, 07:56:39
  log type:  smcl
       log:  c:\data\poe5stata\chap01.smcl
      name:  <unnamed>
                                                                               
(note: file c:\data\poe5stata\chap01.smcl not found)
. log using chap01, replace
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Fill in the resulting dialog box. If the Output File named already exists, you will be queried if you 
want to replace it or not. Select Translate. Alternatively, enter the command 

 
translate chap01.smcl chap01.log, replace 

 
So that the file type will be recognized as a text file, you might instead use 

 
translate chap01.smcl chap01.txt, replace 

1.11 USING THE DATA BROWSER 

It is a good idea to examine the data to see the magnitudes of the variables and how they appear in 
the data file. On the Stata toolbar are a number of icons. Sliding the mouse pointer over each icon 
reveals its use. Click on Data Editor (Browse) 
 

 
 
The browser allows you to scroll through the data, but not to edit any of the entries. This is a good 
feature that ensures you do not accidentally change a data value. Use the slide bar at the bottom  
and the one on the right to view the entire data array. Alter the size of the spreadsheet by dragging 
the “window size” corner. The Data Editor or Data Browser can be open while working without 
doing any harm. 

1.12 USING STATA GRAPHICS 

Stata does very nice graphics of high quality with many tools for enhancing the figures. We 
encourage the use of dialog boxes when learning graphics, combined with careful reading of the 
Graphics Manual (help graph), to learn the scope of graphics features. We will illustrate a 
Histogram and a Scatter Plot. Later in this manual, we will illustrate various options to the basic 
graphs. 

1.12.1 Histograms 
Select Graphics > Histogram on the Stata menu. 
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or enter the command db histogram. In the resulting dialog box there are many options. For a 
simple histogram all you need to do is select is the variable from the pull-down list. For illustration, 
we have entered a title and axis labels by clicking the Titles, Y axis and X axis tabs and filling in 
boxes. Choose Percent to have histogram bin heights reflect percent of sample contained in the 
bin.  

 
 
To name the graph click the Overall tab. 
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Click Submit and the resulting figure is 
 

 
 
Click on the Save graph icon. The resulting dialog box shows that the graphics file will be saved 
into your working directory. Attach a file name and choose the type of graphics file from the drop-
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down list. The default type *.gph is a Stata graphics format, which is convenient if you will do 
further editing in Stata. Other available formats, such as *.png files are widely used for images, 
like screen shots. If the graphs are to be included in document Microsoft Word use the *.emf format 
(Enhanced Metafile), or on a Mac use *.pdf.  
 

 
 
The corresponding Stata command is 
 

graph save wage_hist "histogram of wages", replace 

 

Having saved the file, you can insert the image as a figure into a document in your word processor. 
Alternatively, if you choose the Copy graph icon the figure will be copied to the clipboard, and 
then the figure can be pasted (Ctrl+V) into an open document. Note that our pointing and clicking 
could have been replaced by the command 
 

histogram wage, percent             /// basic command 

     ytitle(Percent) xtitle(wage)   /// titles for axes 

     title(Histogram of wage data)  /// figure title 

     subtitle(cps5_small data)      /// figure subtitle 

     name(wage_hist, replace)        

 
The WAGE variable is continuous. The variable EDUC is the number of years of education, such 
as 12, 14, etc. We can create a histogram for this discrete variable with one minor change, adding 
the option discrete. 

 
histogram educ, discrete percent    /// basic command 

     title(Histogram of educ data)  /// figure title 

     subtitle(cps5_small data)      /// figure subtitle 

     name(educ_hist, replace) 
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Instead of the percentage of the sample with a given number of years of education you may want 
to see the actual frequencies. Use the command option frequency. 

 
histogram educ, discrete frequency  /// basic command 

     title(Histogram of educ data)  /// figure title 

     subtitle(cps5_small data)      /// figure subtitle 

     name(educ_hist, replace) 

 

For a detailed list of the years and frequencies us the tabulate command. Enter db tabulate to find 
some choices. 

 

 
 

For a single variable choose One-way table.  
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The corresponding Stata command is simply 
 

tabulate educ 

 

The result is 
 

 

1.12.2 Scatter diagrams 
A scatter diagram is a Two-way Graph. From the graphics menu select this option 
 

      Total        1,200      100.00
                                                
         21           19        1.58      100.00
         20           25        2.08       98.42
         18          149       12.42       96.33
         16          304       25.33       83.92
         14          124       10.33       58.58
         13          201       16.75       48.25
         12          307       25.58       31.50
         11           18        1.50        5.92
         10           10        0.83        4.42
          9           11        0.92        3.58
          8           10        0.83        2.67
          5           14        1.17        1.83
          3            6        0.50        0.67
          0            2        0.17        0.17
                                                
  education        Freq.     Percent        Cum.
   years of  
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In the dialog box, click Create. 
 

 
 
A dialog box opens. 
 

 
 
Choose the Y variable (vertical axis) and X variable (horizontal axis). Select the Scatter plot, and 
click Submit. The resulting graph can be saved to a file, or copied and pasted into a document, as 
with the histogram. The result shows “dots” for each data pair (educ, wage), and by casual 
inspection we see that more education is associated with higher wages. Aren’t you glad? 

The Stata command used to create this scatter plot is 
 

twoway (scatter wage educ), name(wage_educ, replace) 
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1.13 USING STATA DO-FILES 

While it is possible to point and click your way to success such an approach requires a new pointing 
and clicking odyssey each time you do a new problem. In our view it is more convenient is to use 
Stata’s do-files as a method for executing commands. These are files containing lists of commands 
that will be executed as a batch.  

Do-files are very convenient after having pointed and clicked enough so that the commands 
you want to execute appear in the Review window. If you have been carrying along on the computer 
with the examples we have been doing, then your Review window is a clutter of commands right 
now. Let’s take those commands to a new do-file called chap01.do. The extension *.do is 
recognized by Stata and should be used. 

Right-click in the Review window, and on the pull-down menu click Select All. After all 
commands are selected right-click again and choose Send to Do-file Editor. 
 

 

 
The Do-file Editor is opened. To save this file click on File > Save, or the Save icon, 
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and enter the file name chap01.do. The Stata Do-file editor is a simple text editor that allows you 
to edit the command list to include only those commands to keep. In the file below we have 
eliminated some commands, done some rearranging, and added some new commands.  

 

 
 
Recall that comment lines are preceded with “*” and comments can be added in lines using “//”. 
Long lines can be split using the continuation comment “///”. 

 
* file chap01.do is a comment identifying the file when you open it 
 
version 15.1 specifies the version used. If you have a Do-file used with a previous version and 

wish to recreate the output, then you can specify instead version 11, or whatever. 
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capture log close is protection against the error of trying to open a new log file while another 

is open. 
 
log close should be included at the end and then the translate command to convert the smcl 
file to a log (text) file. 

Note that in the Do-file Editor comments are green, and Stata commands are blue. When using 
do-files, which are collections of commands run together, or in “batch mode,” the replace option 
is used to write over old saved results and graphs with new ones. The remainder of the do-file is 
from the list of commands we have explored. 

To execute this series of commands click the Do icon on the Do-file Editor toolbar.  
 

 
 
The results appear in the Result window and will be written to the specified log file. 

The Do-file editor has some useful features. Several do-files can be open at once, and the Do-
file editor can be used to open and edit any text file. By highlighting several commands in the do-
file and selecting do selected lines parts of the do-file can be executed one after the other. Of 
course the data file cps5_small.dta must be open prior to attempting to execute the selected lines. 
 

 
 

Stata Tip: If the Do-file tab shows an asterisk (*) that means changes have been 
made to the file and the changes have not yet been saved. Be sure to Save the Do-
file! 
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At the end of each chapter in this book we will present a do-file summarizing the chapter. 

1.14 CREATING AND MANAGING VARIABLES 

Stata offers a wide variety of functions that are used to create new variables, and commands that 
let you alter the variables you have created. In this section we examine some of these capabilities.  

1.14.1 Creating (generating) new variables 
To create a new variable use the generate command in Stata. Let’s start with the pull-down menu. 
Click on Data > Create or change variables > Create new variable on the Stata menu. 

 

 
 
A dialog box will open. 
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Alternatively, in the Command window, enter db generate to open the dialog box. In the dialog 
box you must fill in 
 
New variable name: choose something logical, informative and not too long. 
 
Contents of new variable: this is a formula (no equal sign required) that is a mathematical 

expression. In the example above WAGE2 is a new variable that will be the square of wage. 
The operator “^” is the symbol Stata uses for “raise to a power, so wage^2 is the square of 
wage, wage^3 would be wage cubed, and so on.  

 
Variable type: the default is float, which stands for floating point. This relates to the way in which 

the variable will be stored internally. Enter the command help data type if you are 
curious. 

 
Click OK. In the Results window (and Review window) we see that the command implied by the 
menu process is 
 

generate wage2 = wage^2 

 
The command can also be shortened to 
 

gen wage2 = wage^2 

1.14.2 Using the expression builder 
Suppose in the process of creating a new variable you forget the exact name of the function. This 
happens all the time. To illustrate let us create a new variable LWAGE which will be the natural 
logarithm of WAGE. Go through the steps in Section 1.14.1 until to you reach the generate dialog 
box. Type in the name of the new variable, and then click Create, opening Expression builder. 
 

 
 
In the Expression builder dialog box you can locate a function by choosing a category, scrolling 
down the function list while keeping an eye on the definitions at the bottom until you locate the 
function you need. 
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Double-click on the function ln(), and it will appear the Expression builder window 
 

 
 
Now fill in the name of the variable, WAGE, in place of “x” and click OK. 
 

 
 
In the generate dialog box you will now find the correct expression for the natural logarithm of 
wage in the Contents of the variable space. Click OK (which will close the dialog box) or Submit 
(which will keep dialog box open). 
 

 
 
The command will be executed, creating the new variable LWAGE which shows up in the 
Variables window. Stata echoes the command to the Results window 
 

generate lwage = ln(wage) 
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and to the Review window. The simple direct command is 
 

gen lwage = ln(wage) 

1.14.3 Dropping and keeping variables and observations 
Enter the command help drop. There you will find commands and variations for dropping 
variables, or observations.  

 
Drop variables: use drop varlist, where varlist is a list of variables. For example, drop wage2 

lwage will drop these two variables. 
 
Instead of deleting variables using drop, you may wish to only keep certain variables or 
observations. 
 
Keep variables: use keep varlist, where varlist is a list of variables. For example, keep wage2 

lwage will drop all variables except these two. 
 

Should you forget this, from the Stata menu choose Data > Variables Manager 
 

 
 
The Variables Manager window will open where you can change various aspects of the data. To 
drop or keep variables, highlight several and then right-click.  

 

 
 

If you wish to drop or keep certain observations use the pull-down menu Data > Create or change 
data > Keep or drop observations. 
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To drop all observations for which the variable WAGE is greater than 5.50, enter into the dialog 
box 

 

 
 
Or, in the Command window: 

 
drop if wage > 5.5 

 
Drop observations: use drop if exp, where exp is a Stata expression. For example, drop if 

wage > 5.50 will drop all observations for which wage is greater than 5.50, or missing.  
 

Tip: The command drop if _n > 100 will drop all observations in data rows 100 
and above, keeping only the first 100 observations. The variable _n is the 
observation number in Stata, which is an automatic variable that is always present. 

 
Drop a range of observations: use drop in 1/50 to drop the first 50 observations.  
 
Keep observations: use keep if exp, where exp is a Stata expression. For example, keep if 

wage <= 5.50 will drop all observations for which wage is greater than 5.50.  
 
In passing we note that there are many other data utilities, such as for renaming variables. See the 
pull-down list 

 



40   Chapter 1 

   
 

1.14.4 Using arithmetic operators 
The Arithemetic operators are: 
 

+ addition 
- subtraction (or create negative of value, or negation) 
* multiplication 
/ division 
^ raise to a power 

 
To illustrate these operators consider the following generate statements: 
 

generate wage1 = wage+1      (addition) 
generate negwage = -wage      (negative or negation) 
generate blackeduc = black*educ     (multiplication) 
generate blackeduc_south = black*educ*south   (multiplication) 
generate blackeduc_west = blackeduc*west   (multiplication) 
generate wage_yr = wage/educ     (division) 
generate blackeduc_midwest = (black*educ)*midwest  (multiplication) 

 
The last line shows the use of parentheses. Like regular algebra, parentheses control the order of 
operations, with expressions in parentheses being performed first. 

Several of these constructions were for demonstration purposes only. We’ll drop them using  
 

drop blackeduc_west blackeduc_midwest wage1 negwage wage_yr 
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Stata shortcut: With a list of variables to type it is easier to type the command 
name, here drop, and then click on the names of the variables in the Variables 
window. When selected they appear in the Command window. Another way to 
quickly enter a variable name is to take advantage of Stata’s variable name 
completion feature. Simply type the first few letters of the variable name in the 
Command window and press the Tab key. Stata will automatically type the rest 
of the variable name for you. If more than one variable name matches the letters 
you have typed, Stata will complete as much as it can and beep at you to let you 
know that you have typed a non-unique variable abbreviation.  

1.14.5 Using Stata math functions 
Stata has a long list of mathematical and statistical functions that are easy to use. Type help 
functions in the Command window. We will be using math functions and density functions 
extensively. 

 

 
 
Click on math functions. Scrolling down the list you will see many functions that are new to you. 
A few examples of the ones we will be using are: 
 

generate lwage = ln(wage)   (natural logarithm) 
generate elwage = exp(lwage)  (exponential function is antilog of natural log) 
generate rootexper = sqrt(exper)  (square root) 

 
Note that the exponential function is xe . Use the Stata Editor (Browse) to compare the values of 
WAGE and ELWAGE. These are identical because the exponential function is the antilog of the 
natural logarithm. The variable LWAGE is the logarithm of WAGE, and ELWAGE is the antilog of 
LWAGE. The function ln(wage) is the natural logarithm and so is log(wage). In POE5 the notation 

( )ln x  is used to denote the natural logarithm. 
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1.15 USING STATA DENSITY FUNCTIONS 

Enter help functions in the Command window. Click on density functions. There are many 
probability distributions available in Stata, such as the binomial, chi-square, F, normal and t. Stata 
provides several classes of functions for describing each probability distribution. We will discuss 
cumulative distribution functions, or cdfs, and a type of inverse function that permits calculation 
of distribution critical values. This section is for completeness and is meant to serve as a reference 
for when the distributions are encountered.  

1.15.1 Cumulative distribution functions 
If X is a random variable, and x is some particular value, we might like to compute the probability 
that X is less than or equal to x. If F(x) denotes the cumulative distribution function of X, then the 
desired probability is  
 

( )( )P X x F x≤ =  
 
The cdfs for key distributions are: 
 
normal(z) returns the cumulative standard normal distribution for a given z. If X has a normal 

distribution with mean μ and variance 2σ  then Z = (X − μ)/σ is a standardized normal 
random variable, with mean 0 and variance 1. All normal probabilities are calculated in 
terms of the standard normal distribution. That is, 

 
( )( )( ) / ( ) ( )P X x P Z x F z z≤ = ≤ − μ σ = = Φ  

 
where Φ(z) is the common symbol used for the standard normal cdf, rather than F. To use 
the function we must calculate z = (x − μ)/σ.  

 
For the chi-squared distribution we have two functions. One computes the usual cdf value and the 
other computes its complement. If the cdf value gives ( )P X x≤  then complement function gives 
1 ( )P X x− ≤  
 
chi2(n,x) for a given value x > 0, returns the cumulative chi-squared distribution with n degrees 

of freedom. 
 
chi2tail(n,x) for a given value x > 0 returns the reverse cumulative (upper-tail) chi-squared 

distribution with n degrees of freedom. chi2tail(n,x) = 1 - chi2(n,x) 
 
For the F distribution we have two functions. One computes the usual cdf value and the other 
computes its complement. Recall that Stata is case sensitive, and the use of upper case F below is 
required. 
 
F(n1,n2,f) for a value f > 0 returns the cumulative F distribution with n1 numerator and n2 

denominator degrees of freedom. 
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Ftail(n1,n2,f) for a value f > 0 returns the reverse cumulative (upper-tail) F distribution with n1 
numerator and n2 denominator degrees of freedom. Ftail(n1,n2,f) = 1 - F(n1,n2,f) 

 
For the t distribution we have only the “tail” probability function.  
 
ttail(n,t) for a given t value, returns the reverse cumulative (upper-tail) Student's t distribution 

with n degrees of freedom; it returns the probability T > t 

1.15.2 Inverse cumulative distribution functions 
Cumulative Distribution Functions tell us the probability that a random variable X takes a value 
“less than or equal to” a specific value x. The opposite question is “What is the value of x such that 
p probability is to its left?” In this case we are given the probability p = P(X ≤ x) and we wish to 
determine the value of x. These are actually percentiles of the distribution. Stata also provides the 
“tail probability” version that gives the value x such that the probability p = P(X > x). The Statistical 
Tables 2-5 in POE5 report selected percentile values p, which can be computed using these 
functions. 
 
invnormal(p) for a given 0 < p < 1 returns the inverse cumulative standard normal distribution: if 

normal(z) = p, then invnormal(p) = z.  
 
invchi2(n,p) for a given 0 < p < 1 and degrees of freedom n, returns the inverse of chi2():  if 

chi2(n,x) = p, then invchi2(n,p) = x. 
 
invchi2tail(n,p) for a given 0 < p < 1 and degrees of freedom n, returns the inverse of 

chi2tail(): if chi2tail(n,x) = p, then invchi2tail(n,p) = x. 
 
invF(n1,n2,p) for a given 0 < p < 1, numerator degrees of freedom n1, and denominator degrees 

of freedom n2, returns the inverse cumulative F distribution: if F(n1,n2,f) = p, then 
invF(n1,n2,p) = f. 

 
invFtail(n1,n2,p) for a given 0 < p < 1, numerator degrees of freedom n1, and denominator 

degrees of freedom n2, returns the inverse reverse cumulative (upper-tail,) F distribution: 
if Ftail(n1,n2,f) = p, then invFtail(n1,n2,p) = f. 

 
invttail(n,p) for a given 0 < p < 1 and degrees of freedom n, returns the inverse reverse 

cumulative (upper-tail) Student's t distribution: if ttail(n,t) = p, then invttail(n,p) 
= t. 

1.16 USING AND DISPLAYING SCALARS 

When computing a probability or a percentile value we usually want a single value, rather than 
1000 values. Stata allows these single values or scalars [help scalar] to be computed and 
displayed [help display].  
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1.16.1 Example of standard normal cdf 
To illustrate, lets compute the probability that a standard normal random variable Z takes a values 
less than or equal to 1.27. This is computed using the cdf normal. Enter the following commands 
into the Command window. 
 
scalar phi = normal(1.27) computes a scalar variable that is the desired probability. 
 
display phi reports the value of the computed probability on the next line. 

 
 

 
display "Prob (Z <= 1.27) = " phi illustrates inserting text into display. 

 
 

 

di "Prob (Z <= 1.27) = " phi shows that display can be abbreviated di. 
 

 
 
We do not have to first create phi at all. We can simply display the value by including the function 
to be evaluated in the display statement. 

 
di "Prob (Z <= 1.27) = " normal(1.27) 

 

 

1.16.2 Example of t-distribution tail-cdf 
Compute the probability that a t-random variable with n = 20 degrees of freedom takes a value 
greater than 1.27. 
 

scalar p = ttail(20,1.27) 

di "Prob (t(20) > 1.27) = " p 

 

 
 
or  
 

di "Prob (t(20) > 1.27) = " ttail(20,1.27) 

 

 
  

.89795768

Prob (Z <= 1.27) = .89795768

Prob (Z <= 1.27) = .89795768

Prob (Z <= 1.27) = .89795768
. di "Prob (Z <= 1.27) = " normal(1.27)

Prob (t(20) > 1.27) = .1093311

Prob (t(20) > 1.27) = .1093311
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1.16.3 Example computing percentile of the standard normal 
Compute the value of the standard normal distribution z such that p = 0.90 of the probability falls 
to its left, so that P(Z < z) = 0.90. In this case z is the 90th percentile of the standard normal 
distribution. 
 

scalar z = invnormal(.90) 

di "90th percentile value of standard normal is " z 

 
 

1.16.4 Example computing percentile of the t-distribution 
Compute the value t of the t-distribution with n = 20 degrees of freedom such that p = 0.90 of the 
probability falls to its left, so that ( )( )20 0.90P t t< = . In this case t is the 90th percentile of the t 

distribution with 20 degrees of freedom. This problem is complicated by the fact that Stata provides 
only the “tail” function for the t-distribution, so the 90th percentile value is found by locating the 
point such that p = 0.10 of the probability lies in the upper-tail of the distribution, that is 

( )( )20 0.10P t t> = . 

 
scalar t = invttail(20,.10) 

di "90th percentile value of t(20) distribution is " t 

 

 
 

You will note that the 90th percentile of the ( )20t  distribution is larger than the 90th percentile of 

the standard normal distribution. This is as it should be, as the t-distribution is “wider” than the 
standard normal. As noted earlier the invttail function can go into the display statement 
 

di "90th percentile value of t(20) distribution is " invttail(20,.10) 

 

 

1.17 A SCALAR DIALOG BOX 

We will be using scalar functions frequently, yet there is no pull-down menu access to them. 
However there is a trick that can be used. Enter  
 

help scalar 

 
The help Viewer opens. Click on define. 
 

90th percentile value of standard normal is 1.2815516

90th percentile value of t(20) distribution is 1.3253407

90th percentile value of t(20) distribution is 1.3253407
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Alternatively enter db scalar define in the Command window. A dialog box opens in which 
you can enter the scalar name and a function expression. For example let us find a percentile from 
the t-distribution with 20 degrees of freedom. For the 95th percentile we will find the value, say 
t95, of t such that ( )( )20 0.05P t t> =  using invttail(20,.05). In the dialog box we would enter 

the following, and click Submit. 
 

 
 
However the important advantage of this dialog box is if you forget the name of the function you 
seek. Click on Create in the scalar define dialog box, which opens an Expression builder dialog 
box. Locate Statistical functions, and scroll down to t. 

 

         
 
Choose a category of functions, scroll down the function list, using the definition appearing at the 
bottom of the dialog box. Now double-click on invttail(). The function then goes to the 
Expression builder window 
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Fill in the values for n and p that you desire, here n = 20 (degrees of freedom) and p = 0.05 (upper 
tail probability), then click OK. 
 

  
 
In the scalar define dialog box invttail(20,.05) appears, leaving you only the task of naming 
the scalar and clicking OK.  
 

 
 

In the Command window appears the implied command 
 

scalar define t95 = invttail(20,.05) 

 
Here define is optional and can be omitted if desired. The results can be displayed using 
 

di "95th percentile of t(20) is " t95 

 

 
 
While the process of using Create and the Expression builder looks tedious, it is sometimes 
quicker than looking up the required function using the Help menu, unless of course you remember 
the name of the function, which we often do not. 

Close the log file. You may wish to translate it into a text file. 
 

log close 

 
If you use the smcl format of log file (log using chap01, replace) at this point you may wish 
to translate it to a text file 

 
translate chap01.smcl chap01.txt 

1.18 Using temporary scalars 
The Stata Corporation was kind enough to have a Stata professional check our discussions. The 
authors of this book are not “programmers.” We are econometricians who use Stata and we learn a 
great deal in the process of preparing this computing supplement to Principles of Econometrics, 
Fifth Edition. Professional programmers are very cautious when using scalars, and we have been 

95th percentile of t(20) is 1.7247182
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encouraged to explain an alternative that is much safer. To illustrate the problem please execute the 
enter do-file chap01.do. Then enter clear. Then enter 

 
di phi 

 

We find in the Results window 
 

 
 

The scalar phi still exists and will remain in memory even though the data are now cleared. Having 
these lingering objects in memory can cause frustration and errors. It should be noted that the 
command clear all will remove phi.  

An alternative to using scalars is to use a Stata’s tempname facility, to create temporary scalars 
that do not linger in memory. To create the temporary scalars phi_temp and z90_temp, enter the 
command 

 
tempname phi_temp z90_temp 

 
The “_temp” extension is not necessary and we added it to differentiate these from phi and z90. 
To use these temporary scalars use the same commands but enclose the names with the left quote 
(`) and right quote, or apostrophe (’). The commands become 

 
scalar `phi_temp' = normal(1.27) 

display `phi_temp' 

 

scalar `z90_temp' = invnormal(.90) 

di "90th percentile value of standard normal is " `z90_temp' 

 
Everything works as before, except these temporary variables disappear when the data are cleared. 

 

 
 

We can use temporary variables in much the same way. Declare these temporary variables using 
the command tempvar and enclose them in left and right quotes. For example, 

 

.89795768

. di phi

. clear

end of do-file
. 

90th percentile value of standard normal is 1.2815516
. di "90th percentile value of standard normal is " `z90_temp'

. scalar `z90_temp' = invnormal(.90)

. 

.89795768

. display `phi_temp'

. scalar `phi_temp' = normal(1.27)

. tempname phi_temp z90_temp
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tempvar expersq 

gen `expersq' = exper^2 

sum `expersq 

 

 
 

As you see using the temporary variable works fine, but for the variable name. 

CHAPTER 1 DO-FILE [CHAP01.DO] 

The following code includes most of the commands used in the chapter. 
 

* file poe5chap01.do for Using Stata for Principles of Econometrics, 5e 
 
* Stata do-file  
* copyright C 2018 by Lee C. Adkins and R. Carter Hill  
* used for "Using Stata for Principles of Econometrics, 5e"  
* by Lee C. Adkins and R. Carter Hill (2018) 
* John Wiley and Sons, Inc. 
 
*-------------------------------------------------------------- 
* this is a comment 
* 
/* this type of comment "/*  */" can contain other comments  */ 
* 
*-------------------------------------------------------------- 
 
* setup 
version 15.1                   
* cd ~/Documents/poe5stata    // use to change working directory 
clear all                 // use this option if previous work can be erased 
capture log close  
 
log using chap01, replace     // open log 
 
* open data 
use stata/cps5_small 
describe 
 
* assign or modify label 
label variable wage "earnings per hour" 
 
/* 
 With few exceptions, the basic language syntax is 
 
        [prefix :] command [varlist] [=exp] [if] [in] [weight] 
                           [using filename] [, options] 
 
 
    see                language element      description 
    ------------------------------------------------------------------------- 
    help prefix        prefix :              prefix command 
    help command       command               Stata command 
    help varlist       varlist               variable list 
    help exp           =exp                  expression 
    help if            if                    if exp qualifier 
    help in            in                    in range qualifier 
    help weight        weight                weight 

    __000002        1,200    722.2792    668.9408          0       3844
                                                                       
    Variable          Obs        Mean    Std. Dev.       Min        Max

. sum `expersq'

. gen `expersq' = exper^2

. tempvar expersq



50   Chapter 1 

    help using         using filename        using filename modifier 
    help options       options               options 
    ------------------------------------------------------------------------- 
*/ 
 
* summarize and variations 
help summarize 
summarize      
summarize wage, detail   
summarize if exper >= 10   
summarize in 1/50 
summarize wage in 1/50, detail 
summarize wage if female == 1 in 1/500, detail 
 
*-------------------------------------------------------------- 
* path to summarize dialog box via pull-down menu 
* 
* Statistics > Summaries, tables, and tests > Summary and descriptive 
*        statistics > Summary statistics 
* 
* or enter: db summarize 
* 
* or enter: help summarize and find Dialog at top right 
*-------------------------------------------------------------- 
 
help comment 
 
/* -------------------------------------------------------------- 
 
/// is a 'continuation comment'. It tells Stata to view the rest 
    of the line as a comment  
    and to join the next line with the current line. 
 
-----------------------------------------------------------------*/ 
* compact table of summary statistics 
help tabstat 
tabstat wage educ female,           /// list of variables                       
     statistics(n mean sum max min) /// list of statistics 
     columns(variables)             //  put variables in columns                   
 
* histogram menu: Graphics > Histogram 
help histogram 
db histogram 
 
histogram wage, percent             /// basic command 
     title(Histogram of wage data)  /// figure title 
     name(wage_hist, replace)       //  name figure    
 
graph save wage_hist "histogram of wages", replace 
 
* enhanced histogram  
histogram wage, percent             /// basic command 
     ytitle(Percent) xtitle(wage)   /// titles for axes 
     title(Histogram of wage data)  /// figure title 
     subtitle(cps5_small data)      /// figure subtitle 
     name(wage_hist, replace)        
   
histogram educ, discrete percent    /// basic command 
     title(Histogram of educ data)  /// figure title 
     subtitle(cps5_small data)      /// figure subtitle 
     name(educ_hist, replace)   
      
histogram educ, discrete frequency  /// basic command 
     title(Histogram of educ data)  /// figure title 
     subtitle(cps5_small data)      /// figure subtitle 
     name(educ_hist, replace) 
 
* the tabulate command 
tabulate educ         
                 
* scatter diagram 
twoway (scatter wage educ), name(wage_educ, replace) 
 
* creating new variables 
help generate 
 
generate lwage = ln(wage) 
label variable lwage "ln(wage)" 
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generate exper2 = exper^2 
label variable exper2 "experience squared" 
 
drop lwage exper2   // drop the variables 
 
* Computing normal probabilities using scalars 
help scalar 
help functions 
help normal 
 
* an example 
scalar phi = normal(1.27)  // normal cdf 
 
* using display 
display phi 
di phi 
 
display "Prob (Z <= 1.27) = " phi 
di "Prob (Z <= 1.27) = " phi 
di "Prob (Z <= 1.27) = " normal(1.27) 
 
* Computing percentile values 
scalar z90 = invnormal(.90)   // finding a percentile from N(0,1) 
di "90th percentile value of standard normal is " z90 
 
* Computing normal probabilities using local macros 
tempname phi_temp z90_temp 
scalar `phi_temp' = normal(1.27) 
display `phi_temp' 
 
scalar `z90_temp' = invnormal(.90) 
di "90th percentile value of standard normal is " `z90_temp' 
 
* Using temporary variables 
tempvar expersq 
gen `expersq' = exper^2 
sum `expersq' 
 
log close 
 
* Use viewer to examine *.smcl log 
help viewer 
view chap01.smcl 
 
* Use translate to convert *.smcl to text file *.log 
translate chap01.smcl chap01.log, replace 
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